2014+ Jeep Cherokee Forums banner

Smart Key Fail error

6580 Views 21 Replies 8 Participants Last post by  tak0629
Hi guys
My Cherokee Longitude (2016) karked out today.
Door opened fine, but when pressing the Start button, there was no response.
A recall part message on dash relating to steering lock, but that went away.
Then I also get a 'Smart Key Fail' error that seems to be more persistent.
So...steering locked, handbrake on and cannot start the Jeep.

1. Had roadside replace the battery - no change
2. Tried 2xclick to start remotely - no go
3. Tried pressing keyfob against push start button - no go
4. Another spare keyfob doesn't work either
5. Car will lock/unlock. Flashers work. Rear lift will open/close. Emergency flashers will work

Car now towed into Jeep dealer service centre and they tell me that it will be TWO weeks before they can even LOOK at the car. Geez!

Trying to find out what the problem could be and if anyone else has had this issue

Thanks in advance
  • Like
Reactions: 1
1 - 2 of 22 Posts
Refer to this Post: Module 68145593AF information about parts
tak062, delete this Post, double Posting just confuses me.

According to moparonlineparts.com it is a SHAFT LOCK - STEERING COLUM which costs nearly $300 US.
What kind of key fob do you have. There are several kinds. Might need to attach a picture
I don't know enough about the starting system to know if this has anything to do with anything.
Does your Jeep have ESS? Is your odometer flashing if you have power?
Just to rule it out get the Jeep battery tested, note 'state of health' and CCA. Be sure to charge the battery with a battery charger before getting it tested.
It may help if we knew the year, make and model of your Jeep. You probably have a Cherokee not a Grand Cherokee.
Do you have any Check Engine codes? Not sure you can read them unless you can go to the Run position.
Search this Forum for more help. That is what I am going to do next.
This Post seems similar to your situation: Smart key failure, action on the steering wheel
There are others. Search for 'smart key fail' and see if there is anything useful.

Refer to this Post: Smart Key Fail error
See less See more
1 - 2 of 22 Posts