2014+ Jeep Cherokee Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all

Have only had our Cherokee for a week so still learning lots, but have observed one "annoying feature" that i would like some help with. Have tried to look for another post on similar subject but could not find anything so apologies if this has been discussed elsewhere.

We have a Limited model with full Technology and Safety packs. Being in Australia our Limited comes standard with the Uconnect 8.4 nav.

Now my issue. Whilst driving along on certain roads the car beeps at us for what seems to be no reason. There is no message on the display just the beep. Occurs consistently at the same places on the same roads.

Thought it might have been warning me of a upcoming railway line (first time we noticed it) but does not do it at all railways. Perhaps at road safety cameras, but does not do it at all safety camera locations. Perhaps a speed warning, but beeps when going under the speed limit and I have not even set a speed warning that I know of? (not that I constantly speed either). The only thing we have come up with is it is perhaps warning of locations with known safety issues.

Have worked through the various menu’s and cannot see where this is controlled and the cars user manual does not seem to have anything to explain.

Any ideas/help would be much appreciated

Auusie_Ivan
 
  • Like
Reactions: dhh3

·
Registered
Joined
·
10 Posts
Welcome Aussie_Ivan,

If you switch the Uconnect 8.4 to Navigation mode then you should see the warnings
for speed cameras and school zones etc...Just need to disable all the warnings from your Nav settings to disable the annoying beeps...;-)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks dragon

Will have another look tonight, but must admit I thought I had been through all the menu items in the UConnect Settings and the Navigation settings and could not find anything where you had the option to turn warnings for such things on or off.
 

·
Registered
Joined
·
455 Posts
Thanks dragon

Will have another look tonight, but must admit I thought I had been through all the menu items in the UConnect Settings and the Navigation settings and could not find anything where you had the option to turn warnings for such things on or off.
You need to press Nav and then Settings to disable the safety camera feature.
 
  • Like
Reactions: aussie_rob

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks SJetc

looked last night and found one item related to Safety Camera Announcements. Have unticked it but have not been out for a drive since. Will see what happens over the weekend.

But does nto explain why i am getting beeps at intresections that are not even controlled by stop lights or at railway lines (but not all).
 

·
Registered
Joined
·
1 Posts
Thanks SJetc

looked last night and found one item related to Safety Camera Announcements. Have unticked it but have not been out for a drive since. Will see what happens over the weekend.

But does nto explain why i am getting beeps at intresections that are not even controlled by stop lights or at railway lines (but not all).
Hi Aussie_Ivan,

I am in Sydney, Australia.
I had the same problem with you after I got my 2014 Grand Cherokee Limited serviced yesterday. They updated the radio software and it seemed that it started to happen after that. I already drove it with disabling safety camera option but it still happened. If you find any good solution please let me share it.
I am going to the service centre today and try to find a solution from them.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Hi B_K and Skywalkerwj

unticking the Safety Camera Announcements has fixed most of my problem. Did a fair bit of drivingn over the weekend in areas the car used to beep at me and all gone, except one particular spot which i guess i will put up with.

Seems the Nav software has any potential area with a safety issue coded as a safty canera hence all the beeps, ie railway lines, school crossings, black spot intersections etc etc.

Only downside is it now won't alert me to actual Red Light camera's (which any aftermarket GPS does as routine) (they still appear on the map if you have it on the screen) but guess lesson here is to stop at any red lights and i wont need to know if there is a camera there or not!!

you need to turn off the safety camera annoucements not the safety camera option. (from memory it is the next option down from the Safety Camera itself in the speed alert section of the Navigation set up).

hope this helps.
 

·
Registered
Joined
·
6,359 Posts
It could be that the radar sensors are covered up with dirt or ice. If blocked, those beeps come and go at odd intervals...
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
thanks taatmk

Ice/Snow certainly not an issue in Western Australia. With min/max temperature around 65/95 deg F every day for last 3 months no possibility of any frozen stuff.

have checked the sensors and they are all clean, car gets washed each week and already two coats of wax in 3 weeks of owndership.

The remaining beeps occur at exactly the same place on a particluar road for me.

Will just live with them as turnign the Safety Camera announcements off has solved 98% of the beep issues.
 

·
Registered
Joined
·
1 Posts
Aussie-Ivan. Had my 2014 longitude serviced last Friday with software upgrades for tansmission and audio/Uconnect. Ever since I get a soft double beep coming from under the dash in usually a series of four beeps. Intermittent and annoying back to the dealer I guess.
 

·
Registered
Joined
·
1 Posts
Re: Beeping....we were on vacation and our 2015 Jeep Cherokee Limited started beeping and would not stop even when turned off. We took it to a dealer and they said it was the radio sensor. It also affected our navigation screen (showed our car was in the middle of a lake and I couldn't get phone reception). They said it would affect everything in that area. It started beeping again on our way home but when we turned the engine off it stopped and has not started up again. Makes me a little uncomfortable not knowing what/when it will happen again.
 

·
Registered
Joined
·
1 Posts
I have the same problem. Seems to be on the same roads that it randomly beeps. I am wondering if it is radar or RF related. One road is right outside a TV Network and the other is near a radio transmission tower.
 

·
Registered
Joined
·
7 Posts
Welcome Aussie_Ivan,

If you switch the Uconnect 8.4 to Navigation mode then you should see the warnings
for speed cameras and school zones etc...Just need to disable all the warnings from your Nav settings to disable the annoying beeps...;-)
Thanks dragon,
I had same annoying beeps exactly as described by aussie_ivan. Disabling the safety cameras in nav worked as you recommended, so many thanks :smile:.

To be precise for other people that have this problem (seems Australian software only) you go to Navigation/Settings/Speed Limit screen and un-check "SHOW SAFETY CAMERAS ON MAP" (Please see attached pic).

This disabled all the annoying beeps, but of course leaves the issue that I can't turn on speed camera warnings, so will raise this with the dealer.

Other issue with this new software update is that the street navigation announcements are distorted and most times don't complete full pronouncing of the street names. Anyone noticed this? - almost as though there is some form of corruption in the memory. Will also raise with the dealer.

BTW the under Settings/System Information, my software version shows as 14.25.5 - I'm assuming this is the overall Uconnect version of software?
 

Attachments

·
Registered
Joined
·
2,286 Posts
We don't have buit-in nav but we do have a Garmin and it beeps annoyingly at school crossings. It always drives me mad worrying if something is wrong with the car! - Ted
 

·
Registered
Joined
·
282 Posts
[

Only downside is it now won't alert me to actual Red Light camera's (which any aftermarket GPS does as routine) (they still appear on the map if you have it on the screen) but guess lesson here is to stop at any red lights and i wont need to know if there is a camera there or not!!

yo
hope this helps.[/QUOTE]

Having the same issues, love my TH, but the Garmon navigator is left wanting- it struggles in Sydney that is for sure. Getting the audible warnings for just speed cameras only is not attainable it seems. Also, there is no facility to add cameras as they are installed. I'll be dusting off the Tom Tom and sticking it on the windscreen as this is a far superior system than the factory installed one.
 

·
Registered
Joined
·
304 Posts
I just got my trailhawk yesterday, and noticed the same thing, dealer and service people were no help, I finally (after much fustration) found turning off speed and camera alerts no more beeping.


On a side note I type in the VIN number to the uconnect site and it says I have a software update, but I donwloaded it to a USB, and the car won't upfate software ? does the latest update to the software fix this ?
 

·
Registered
Joined
·
35 Posts
Hi I just purchased a Cherokee limited 2014 model (Australia) and I am experiencing the same problem , I searched all over for a fix until I came upon this site and forum which describes the problem exactly. I will turn off the camera warnings tonight and see if this problem stops. Thanks . I did however updated the software to 15.26.1 but no change.
 

·
Registered
Joined
·
1 Posts
go to where the speed camera warning is & untick ( I think it picks up household cameras signals )
works for me turning off - drove me nuts and with trial n error no more beeps
I have the over speed limit on & that saves me for sure as I creep up in speed as we all do !
( pity Jeep where I bought it from ( Rockingham WA ) couldnt tell me this info - they had/have no idea
and never got back to me !
 
1 - 20 of 22 Posts
Top