2014+ Jeep Cherokee Forums banner

21 - 22 of 22 Posts

·
Registered
Joined
·
1 Posts
I had same problem wi
UPDATE:
I had the issue again yesterday where none of my USB ports were working. I Googled searched the issue and pulled up a thread on Wrangler Forum. There seems to be quite a few people there who have experienced this issue quite frequently. A Jeep representative responded with the following suggestion (which I have tried and they started working again, hopefully the issue is resolved) -
On iPhone, go to Settings.
Then go to Touch ID & Passcode. (enter passcode)

Scroll all the way down to USB Accessories. (Turn On)


Hopefully that does the trick!
I had same problem with my 2019 grand cherokee over land
This trick helped me to get it back working again
Thank you so much 🙏🙏
 

·
Registered
Joined
·
1 Posts
Hello All -
I am experiencing some periodic issues with the usb ports in my 2019 Trailhawk. Some times they work and others they do not. Not sure If I am doing something wrong or not. I leave my iPhone cord in the console usb so I can use Apple Carplay and I have a brand new 32 gb thumb drive I use in the main usb port below radio for music. Sometimes it recognizes it and others it does not. After leaving them plugged in over night, this morning they would not recognize anything. I even tried plugging into the ports in the back seat and still nothing. Then after a while it finally started to recognize the thumb drive and started playing music.
Is this normal behavior? I would think you just leave stuff plugged in and it should recognize with no issues etc.
Also - how do you soft reboot the system?

Thank you in advance
Same exact issue on 2018 Jeep Grand Cherokee Limited Sterling Edition. It was intermittent. The USB hubs in the front either worked or they didn't. They never stopped/started working mid use it was always when you get into the vehicle upon start up they would intermittently connect and work or they would not. There was no rhyme or reason to it. One day/One week they work. The next day/week they wouldn't work. Here is the key. Only take it into the dealership when it's NOT working. I went in and discussed with a service adviser the issue and got his name and phone number so I could text him. It was agreed that the next time it was presenting itself as an issue I would text him to make sure he was in and take it in. I did so and they told me they locked the problem. The USB ports themselves have a connect behind them as an intermediary between the hub ports themselves and the infotainment center. THAT was the issue. He told me it was not working/showing power. They swapped that part which was 169.00 (but covered under warranty) and I have had zero issues since.
 
21 - 22 of 22 Posts
Top