2014+ Jeep Cherokee Forums banner
41 - 60 of 70 Posts

·
Registered
Joined
·
1 Posts
Has anyone come up with a solution on this yet? seems to only be noticeable at low speeds (always hear it when driving through a parking lot, or our neighborhood). We took our 2017 Trailhawk 3.2L in at about 50k miles with this issue, took forever to get the dealer to replicate it (of course) and they finally did. It was still under warranty, so they replaced the rear differential. The service manager at the dealership claimed that it was a "dust seal" that is not a replaceable part, so the whole unit had to be replaced. Now, at about 75k miles, the squeak has returned. We are now outside of warranty and I am curious as to if anyone has found a way to actually correct the issue beyond replacing the entire differential every 30k miles.

If anyone is curious, someone on Youtube did a great job capturing exactly what we are hearing:

Thanks
Just wondering if anyone has an easier solution fix other than having the rear diff changed?
I’m in the same situation with my 2015 TH; had the diff changed twice under warranty and both times the noise comes back after about 30k at low speeds after drivetrain is warm. Very frustrating.
 

·
Registered
Blackbird 2019_Limited_4x4 Blk_on_Blk Tech_Lux_Nav
Joined
·
2,404 Posts
Maybe try slapping some 'marine grease' on it?
 

·
Registered
Joined
·
226 Posts
Mine has been doing it since new. Only on hot days. Dealer replaced brake pads, then axle seal, the whole rear diff.

Went away for a few months but its come back.

Most annoying thing ever.



Sent from my SM-G930W8 using Tapatalk
 

·
Registered
2019 Trailhawk Elite 2.0T
Joined
·
152 Posts
Had/have this exact issue on both my KLs. Hopeful for at least a temporary but repeatable solution.

Dealerships often insist on changing for a brake system cleaning before looking anywhere else.

If it were as simple as applying lubricant every 6 months or so, I would be satisfied.
 

·
Registered
2019 Trailhawk Elite 2.0T
Joined
·
152 Posts
I pursued the issue heavily with my first KL. New driveshaft, hub 3 brake system cleanings.. and then I traded it in for my current KL.

I mentioned the issue on my current KL twice, and they were unable to replicate (as they they wouldn't drive it long enough for the seal to heat up and start making the noise).

All in I'm at over 10 dealer visits between 2 vehicles on this, so I would rather find a DIY solution.
 

·
Registered
Joined
·
226 Posts
I pursued the issue heavily with my first KL. New driveshaft, hub 3 brake system cleanings.. and then I traded it in for my current KL.

I mentioned the issue on my current KL twice, and they were unable to replicate (as they they wouldn't drive it long enough for the seal to heat up and start making the noise).

All in I'm at over 10 dealer visits between 2 vehicles on this, so I would rather find a DIY solution.
I've had rear brake pads replaced, rear axle seals, rear diff, 4 brake cleanings. What a joke. Now they say can not duplicate. Yeah right. It goes back in Monday.

Sent from my SM-G930W8 using Tapatalk
 

·
Registered
2020 TH 3.2L Granite Crystal Cold Weather
Joined
·
4 Posts
So hi everyone, I just bought my 2020 TH in May. Bought off lease turn in at 46k miles. Drove from Denver to Omaha to pick it up and once back in Denver I started hearing the squeak. Like many of you, brought it in and was told couldn't replicate, so I went and took the tech for a ride until he heard it, next day was told pebbles stuck between the brake shield and rotors and they cleaned it out and said the noise couldn't be replicated. I go bring back the loaner and pick up my TH... by the time I drove home I heard squeaks in my parking garage. I had the same thought as many of you that it was my RDU but it shouldn't be wearing out at 46k with the way it felt driving, it didn't make sense. I've taken to spraying white lithium grease inside the dust deflector and it had taken care of the noise for approximately 6k miles, when it returned quieter than before, I stopped in a parking lot and sprayed again. I now keep a can of white lithium grease with me and I'm squeak free. My guess is the axle seal dries out on these RDU, perhaps the suggestion of marine grease is a better way to go. I think I'll try it next time the squeak returns... I'm guessing another 4k miles or so from now. Will update with any different results. Cheers guys!
 

·
Registered
Joined
·
226 Posts
So hi everyone, I just bought my 2020 TH in May. Bought off lease turn in at 46k miles. Drove from Denver to Omaha to pick it up and once back in Denver I started hearing the squeak. Like many of you, brought it in and was told couldn't replicate, so I went and took the tech for a ride until he heard it, next day was told pebbles stuck between the brake shield and rotors and they cleaned it out and said the noise couldn't be replicated. I go bring back the loaner and pick up my TH... by the time I drove home I heard squeaks in my parking garage. I had the same thought as many of you that it was my RDU but it shouldn't be wearing out at 46k with the way it felt driving, it didn't make sense. I've taken to spraying white lithium grease inside the dust deflector and it had taken care of the noise for approximately 6k miles, when it returned quieter than before, I stopped in a parking lot and sprayed again. I now keep a can of white lithium grease with me and I'm squeak free. My guess is the axle seal dries out on these RDU, perhaps the suggestion of marine grease is a better way to go. I think I'll try it next time the squeak returns... I'm guessing another 4k miles or so from now. Will update with any different results. Cheers guys!
Could you please make a video or some pictures to show where u spray the grease? Thank you

Sent from my SM-G930W8 using Tapatalk
 

·
Registered
2020 TH 3.2L Granite Crystal Cold Weather
Joined
·
4 Posts
Tire Wheel Automotive tire Synthetic rubber Rim
Automotive lighting Automotive tire Hood Vehicle Motor vehicle

Those two give you a better idea where I'm talking? It's right where the axle seal is. I believe it dries out thus creating the noise we hear, others have suggested the same and I'm with them. There are three other KL TH in my parking garage and at least one squeaks the same, plus I've heard some in parking lots doing it. Seems a common RDU (if not just TH) issue. Best of luck, happy to assist where I can.
 

·
Registered
Joined
·
226 Posts
View attachment 219899 View attachment 219900
Those two give you a better idea where I'm talking? It's right where the axle seal is. I believe it dries out thus creating the noise we hear, others have suggested the same and I'm with them. There are three other KL TH in my parking garage and at least one squeaks the same, plus I've heard some in parking lots doing it. Seems a common RDU (if not just TH) issue. Best of luck, happy to assist where I can.
Thanks. That helps alot. How do u get behind there?

Sent from my SM-G930W8 using Tapatalk
 

·
Registered
Joined
·
226 Posts
I just use the small red tube that comes with the grease. Aerosol white lithium grease is all I've used so far.
One more question. Mine starts squeaking only when its hot put and only after driving for half hour or so. I assume things get hot causing the noise. What was your situation? Noisy when hot? All the time?

In the winter I dont have squeals.

Sent from my SM-G930W8 using Tapatalk
 

·
Registered
2020 TH 3.2L Granite Crystal Cold Weather
Joined
·
4 Posts
One more question. Mine starts squeaking only when its hot put and only after driving for half hour or so. I assume things get hot causing the noise. What was your situation? Noisy when hot? All the time?

In the winter I dont have squeals.

Sent from my SM-G930W8 using Tapatalk
I haven't had it long enough to tell whether or squeals in winter, just bought it beginning of May. Otherwise, it was noisy once it heated up after some driving, if cool I couldn't hear it in my garage or driving near buildings, only after some heat build up.
 

·
Registered
Joined
·
226 Posts
I haven't had it long enough to tell whether or squeals in winter, just bought it beginning of May. Otherwise, it was noisy once it heated up after some driving, if cool I couldn't hear it in my garage or driving near buildings, only after some heat build up.
Exactly like mine. Thanks for the pictures and time to reply.

Sent from my SM-G930W8 using Tapatalk
 
41 - 60 of 70 Posts
Top