2014+ Jeep Cherokee Forums banner
1 - 20 of 38 Posts

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #1 ·
I was driving when my MY14 Cherokee lost power, noticed it was in neutral. Everytime I tried to put it into D or R it would say put into park then select gear. Service 4wd would flash then stay on, and every 30 seconds the service parking brake would turn on then go off. Odometer flashing constantly. All recalls have been completed, I towed to a dealership on Friday and today they just got it into the shop, only thing tech has done is found water pooling somewhere in the back. I will be going in tomorrow to get more info but has anybody else had this issue?
 

·
Registered
Joined
·
12,262 Posts
I was driving when my MY14 Cherokee lost power, noticed it was in neutral. Everytime I tried to put it into D or R it would say put into park then select gear. Service 4wd would flash then stay on, and every 30 seconds the service parking brake would turn on then go off. Odometer flashing constantly. All recalls have been completed, I towed to a dealership on Friday and today they just got it into the shop, only thing tech has done is found water pooling somewhere in the back. I will be going in tomorrow to get more info but has anybody else had this issue?
You should start with this : https://static.nhtsa.gov/odi/rcl/2015/RCRIT-15V393-6798.pdf

Odometer flashing means dealership will need to perform a proxy align. Hopefully the recall, if not performed on your Jeep already, can cure all of this...

I know we have other members who've had the water leak with problems, perhaps one or a few will chime in...
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #3 ·
I do not have the power lift gate so the recall doesn't apply but the symptoms closely resembles the R55 recall which supposedly was done when they put a new transmission in the vehicle. I need to check my paperwork but I'm pretty sure the transmission was done in April of 2016, that recall is dated July 2016 so how did they perform the recall before it was released. I may need to get in touch with Jeep Cares because I think the dealer falsified that recall. Anyways I read through a lot of other post on here that are close to mine but all had 1 symptom dofferent.
Also when I tried starting the car while diagnosing the issue its like the starter would intermittently get the signal and stop after 2 cylinders fire then try to start again and after 2 or 3 attempts it would start. While going through these attempts to the the whole car would lurch/shake like its was wanting to be in gear.
 

·
Registered
Joined
·
4,030 Posts
Is your Cherokee a Trailhawk?
Could this be a RDU problem?
You should have lots of Codes and the Check Engine light should be ON?
There is a remote possibility the tone ring in one of the wheel hubs is cracked. I think I am the only person to have that failure.
As usual it could be the battery.
I thought there were more "Service 4WD" posts on this forum but I can't seem to find them.
I am really confused. Let us know what the dealer finds.
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #6 ·
Dealership called back stating the water in the back was getting the parking brake module wet. The tech was able to dry it out and feels a software update/proxy alignment should fix it. I just approved the work so I will update around 3pm when they call me after a test drive. I had the battery tested before I had it towed, it was good. I really hope this fixes it and I'll try and get a copy of the codes the tech pulled to narrow down other people's issues.
 

·
Registered
Joined
·
4,030 Posts
Somewhere on here recently there was a post where water was leaking into the trunk area underneath the liftgate seal that is attached to the body.
Hopefully somebody can find the post.
Make sure there are no open bolt holes where the gas struts attach to the body.
 

·
FCA Customer Support Group
Joined
·
1,500 Posts
I do not have the power lift gate so the recall doesn't apply but the symptoms closely resembles the R55 recall which supposedly was done when they put a new transmission in the vehicle. I need to check my paperwork but I'm pretty sure the transmission was done in April of 2016, that recall is dated July 2016 so how did they perform the recall before it was released. I may need to get in touch with Jeep Cares because I think the dealer falsified that recall. Anyways I read through a lot of other post on here that are close to mine but all had 1 symptom dofferent.
Also when I tried starting the car while diagnosing the issue its like the starter would intermittently get the signal and stop after 2 cylinders fire then try to start again and after 2 or 3 attempts it would start. While going through these attempts to the the whole car would lurch/shake like its was wanting to be in gear.
Hi ericyost19,
Can you send us a message with your VIN and dealer info? We would like to look into this for you.

Rob
Jeep Cares
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #9 ·
Hi ericyost19,
Can you send us a message with your VIN and dealer info? We would like to look into this for you.

Rob
Jeep Cares
I was mistaken i logged into my Jeep dashboard on the mopar website and confirmed the recall was completed before a roadtrip for my anniversary when I brought it in for an inspection. Paperwork in my files confirmed they completed the recall while it was in for inspection, that service slipped my mind. Crown Jeep got my car back to me in less than 24 hours from start to finish and I couldn't be happier with their service everytime.

Sent from my SM-G965U using Tapatalk
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #10 ·
Just picked up the Jeep and put 60 miles on it with no issues. They charged 2 hours 1 for diag. And 1 for repair/computer scan for proxy alignment and relearning. The two cubby on either side of the cargo area had standing water the technician found abnormal CAN BUS voltages causing a lot of systems to go haywire. He dried out the area and cleaned the connectors. I will be doing a leak test on my own to find where the water is coming from and update on here. But if anybody else is having this issue they may want to check the cargo area cubby for water.

Sent from my SM-G965U using Tapatalk
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #12 ·
Pulled up the back cargo carpet and a bunch of trim loose and saw where the sound dampening wet along the bottom of both sides. Passenger side is a wire pass through and driver side it a plug i have removed in the pictures to let it dry out and to show the white ring on the bottom shows the plug had a complete seal so o don't thing water is coming in from the bottom but there is no sign of it running down the sides behind the C and D pillar. I suspect its running around from the hatch somewhere.


Sent from my SM-G965U using Tapatalk
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #13 ·
I believe I found the source of the leak and I can't believe it didn't come to mind right away. There is a seam where the roof meets the quarter panel that gets cracked I believe from body flex, I don't off road, that I have seen on my vehicle and a couple of friends vehicles. Im gonna take water to it and test my theory but this should be looked at for tsb or recall in the future as our jeeps age. Does anybody have a recommendation on what to use to seal it?


Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
12,262 Posts
I believe I found the source of the leak and I can't believe it didn't come to mind right away. There is a seam where the roof meets the quarter panel that gets cracked I believe from body flex, I don't off road, that I have seen on my vehicle and a couple of friends vehicles. Im gonna take water to it and test my theory but this should be looked at for tsb or recall in the future as our jeeps age. Does anybody have a recommendation on what to use to seal it?


Sent from my SM-G965U using Tapatalk
Yikes. Good find. This could be the first of many... with aging Cherokees... Not sure I've read from others on this forum about this though.
Could you possibly get us another picture, zoomed out so we can see where roughy this seam is with perspective ? Thx.
 

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #15 ·
Its getting dark but I made arrows pointing to their location. I would take a quick gander at it next time you open your hatch, like I said ive seen a couple like it. Im still gonna do a leak test with the hatch closed to make sure this is the source.


Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
12,262 Posts
Its getting dark but I made arrows pointing to their location. I would take a quick gander at it next time you open your hatch, like I said ive seen a couple like it. Im still gonna do a leak test with the hatch closed to make sure this is the source.


Sent from my SM-G965U using Tapatalk
Got it. Thanks. I will look at my 2015 when I get a chance...
 

·
Registered
Joined
·
308 Posts
Mine is cracked in those exact same spots, I noticed it a while back when someone else posted about theirs being cracked and having a water leak.
 
  • Like
Reactions: Mark_

·
Registered
2014 AD1 2.4l
Joined
·
63 Posts
Discussion Starter · #20 ·
If you have the cracks i would pull the triangle cubbies in both corners of the back cargo and fell down in there for moisture.

Sent from my SM-G965U using Tapatalk
 
1 - 20 of 38 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top