2014+ Jeep Cherokee Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Since a few days, after I start my 2019 Cherokee, the right signal light, daytime running light and regular headlight stop working after about 3 minutes.
could this be a fuse and if so, where can I find these fuses in the car?
Thanks in advance
Fred
 

·
Registered
Joined
·
1,038 Posts
Sounds like a heat-related issue. A blown fuse would mean those things would work at all.

Heat issues are a bear to find. You can get a can of electronics freeze spray and hit anything that looks interesting to see if the problems resolve themselves. Other than that, good luck!
 
  • Like
Reactions: Ferry van Lier

·
Registered
2015 Cherokee Trailhawk
Joined
·
833 Posts
True about the fuse - when it opens, that's it and would both sides be on the same fuse? It absolutely sounds like it's heat-related. Have any of the lights been changed out (mods, etc.) or area(s) repaired?. Go into 'Settings' and unselect 'Daytime Running Lights' o get those out of the equation and then break it down from there.
 

·
Registered
Blackbird 2019_Limited_4x4 Blk_on_Blk Tech_Lux_Nav
Joined
·
1,508 Posts
I'd start with the plug to the Headlamp Unit, all those lights are on separate circuits...
But the Ground Wire from the Headlamp Unit is common for all circuits...
So my guess is a loose/bad ground, or the plug is not seated...
There is also an intermediate plug for it XY102A somewhere along the harness that could be loose, but I can't tell you where that is located...

Good Luck! :cool:
 
  • Like
Reactions: Flybynightcru
1 - 5 of 5 Posts
Top