2014+ Jeep Cherokee Forums banner
21 - 35 of 35 Posts

· Registered
Joined
·
195 Posts
After re reading post I see the end of gray coming from unit grounds to black wire. Correct? I got the visor today and just needed a cleaning. Does the homelink unit come off allowing access to wires to make it easier?


Sent from my iPhone using Tapatalk

Got it all wired up and Homelink Buttons Light up when pressing, can't program until the morning but looks good. Thanks for the tip and will be a nice upgrade from having remote hanging from other visor. I did use wires coming from headliner. Pulled off tape and removed a little bit of plastic on black wire, cut the grey and striped end from visor side and wrapped around stripped part of black, cap the other end, taped it all up and everything works. Pretty easy and cheap upgrade.
 

· Premium Member
Joined
·
755 Posts
Just did this myself. Did my clipping on the vehicle side of the harness, as there was much more wire to work with. Clipped the grey wire, bonded to the black, boom, working homelink.

I ordered the visor from a salvage shop, and I cleaned it up a bit after receiving it. Then diritied it quite a bit installing it. The cloth tape that covers the wires has residue that will stain the visor, and will need cleaning if one does not stop to clean their hands before wrangling the visor in to place.
 
  • Like
Reactions: scottb and Array

· Registered
Joined
·
27 Posts
Any solution for this yet? Just installed a HL equipped visor out of a '16 KL and I have the same issue. What does the 3rd pin in the connector do? Yellow is the 12v visor feed, center black is ground. What is the grey wire? No power on it with a DVOM, does show continuity to ground with DVOM. HL lit up in donor vehicle, no lights when connected in mine. Thanks!
 

· Registered
Joined
·
195 Posts
Yes, the way to wire it is earlier in the thread. Worked perfect for me. Look on page 2


Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
27 Posts
Yes, the way to wire it is earlier in the thread. Worked perfect for me. Look on page 2


Sent from my iPhone using Tapatalk
Thanks, just went out in the garage and tried that, it works! Sweet. Now to be able to permanently disable the start/stop system.
 
  • Like
Reactions: dhh3

· Registered
Joined
·
4 Posts
HI, I have been following your thread as I had the same issue. I have done the steps to cut the grey wire and currently just have both ends taped because I don't understand what is meant by grounding that to the black wire LOL sorry never done anything like this before.

Now nothing on the visor works lol I assume I might have to ground the grey wire to the black by splicing that in? If anyone had a photo of a completed modification that would be great.
 

· Registered
Joined
·
195 Posts
HI, I have been following your thread as I had the same issue. I have done the steps to cut the grey wire and currently just have both ends taped because I don't understand what is meant by grounding that to the black wire LOL sorry never done anything like this before.

Now nothing on the visor works lol I assume I might have to ground the grey wire to the black by splicing that in? If anyone had a photo of a completed modification that would be great.


Yes cap the grey wire going into headliner. Then strip some of black plastic from wire. Attached stripped end of Grey from visor to stripped part of black and tape. Should work after doing that. Sorry don’t have pictures


Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
195 Posts
Thank you. What did you use to cap the grey wire going into the headliner? I am sure what gauge this wire is but nothing i have for caps will work for this type I will get some.

Thanks!
John


I had a small wire cap. U can prob just tape it good


Sent from my iPhone using Tapatalk
 

· Registered
2015 Cherokee Latitude North Edition, V6 Cold Weather package, Nav system, Uconnect
Joined
·
58 Posts
Homelink Visor Issue

Was able to use the information in these posts to add Homelink to my 2015 Cherokee Latitude North Edition. Like most everyone has said, tying the gray and black wires together made the Homelink visor unit work.
I wanted to say thanks to this forum, made my day!! :smile:

-BobC
 
  • Like
Reactions: ArizonaFred

· Registered
Joined
·
1 Posts
Hey, I made an account just to post this! I have a 2015 Chrysler 200 Limited and they do not have the option for HomeLink. Only the 200C. I purchased a visor and just like many of you saw three connections and was like sweet it will work! But it didn't. It got me to thinking about the Diagram posted above with the UGDO Enable Circuit. I assume only cars that come with HomeLink have that circuit and that is why when we try to add HL it does not work. Turns out that control wire just needs to see ground to activate HL. So ground the wire and you are good to go!

TL;DR: Cut the gray wire, cap the end that goes into the headliner then ground the other end to the black wire and it will work.
Awesome. Thank you. I was driving myself crazy trying to figure out why it was not working. The visor now works as it should.
 

· Registered
Joined
·
142 Posts
I finally got around to adding Home link Visor. Dealer wanted 1 hour at $125 to enable the Body control module for the visor.
No Thanks, I park inside a garage so I wasn't concerned about the Home Link always working with the cutting and splicing the gray wire to the black. ( Described above )
After unwinding the wire wrap, I cut the gray wire then stripped the end by the connector. I opened up the connector by pushing the small gray release and pulled this out of the connector.
I then CAREFULLY inserted the gray wire next to the black wire, away from the yellow wire.( which is +12VDC) Put small connector piece back in. rewound wire wrap wire wrap. Reassembled and then, Zipped Do Da, Home link Programmed and working.




Electronics Technology Electronic device Cable Fashion accessory
Handbag Bag Fashion accessory Birkin bag Tote bag
 

· Registered
Joined
·
27 Posts
I just bought a 2019 Trailhawk and it does not have homelink or the auto dimming mirror. Are these things easy to install? Is the wiring there already? Where is the Security Gateway? I use AlfaOBD on my Challenger so enabling it in the BCM should not be too difficult. Also is it possible to turn off "Start/Stop" with AlfaOBD? There is an option in the BCM.
Thanks in advance.
 
21 - 35 of 35 Posts
Top