2014+ Jeep Cherokee Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 · (Edited)
Hey all!

So, the TH has a weird issue that developed recently. When you turn the wheel, especially on any sort of slope, there is a clanking or knocking noise coming from somewhere in the front axle/power steering rack area. I will upload a video in a minute.

I took it to the stealership as I recently added a maxcare warranty to cover it for 8yr/85k miles. Currently the TH is a 2018 with 33k miles. Haven’t done much “off-roading” aside from some country/gravel roads a few times (nothing crazy). Usually just a kid fetcher/DD/grocery getter lol

What I’m most mad about is 2 things:

1. Mopar denied the initial claim today, dealer says they will send in a petition or whatever to try and get it covered. Their reasoning is supposedly that this was a “pre-existing” issue to the warranty. The vehicle was under factory warranty till March. I added the Maxcare in April. They are trying to play some game of it not being under warranty for a month or something and say this is pre-existing…about the most ridiculous thing I’ve heard. When buying the warranty, was told I didn’t need any sort of inspection prior. It’s been 2 months since I bought it when this happens and apparently that’s somehow pre-existing…anyone dealt with MVP plans pulling this BS?

2. it doesn’t seem like the dealer even diagnosed anything as my printout literally says:

rack and pinion, power steering - replace

total for that is $4836!!!!?!?!?

anyone had any issues like this, about to go crawl around under it and see what I can see…I can’t comprehend why the whole thing would ever need replaced, let alone at 33k miles. Sure hope this somehow just gets cleared and fixed by the dealer but not leaving a good first impression of my warranty in general…

thanks

Edit:

here’s the video


The car is in the on position in this video, not running. Just giving the wheel a little back and forth. It is on a downward slope:

 

·
Registered
Joined
·
50 Posts
Not sure if it’s an issue but I’ve never noticed my strut move nearly as much as yours just did. Maybe it normal but might be worth checking out.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Yeah, I was looking at that, however, there was no noise coming from there specifically.

update on the issue though. I crawled under the car last night extensively listening for any noises. It’s gone completely. Even driving around there is nothing. Now I’m thinking the dealer is trying to just make a ton on something they didn’t diagnose and don’t need to replace (probably primarily because of the warranty). The appeal to the claim still hasn’t come back but I don’t think I’m going to have any work done by this dealer, seems shady. I’m thinking of just having another dealer do an inspection and give it a good bill of health and just see if it ever comes back again. Still need to sort out the denial, because if they are going to play the pre-existing game, I don’t see how this warranty will ever cover anything…
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
My other thought is potentially a rock was stuck somewhere making that noise from driving on a logging road and has now dislodged. Definitely going to have to wait and see what happens but car is driving/handling just fine, noise free.
 
1 - 4 of 4 Posts
Top