2014+ Jeep Cherokee Forums banner
21 - 34 of 34 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #21 ·
Might be the issue. This is Non Nav and I had Nav before.
I took a look through the status logs. There just wasn't much there that wouldn't be obvious to what could be causing it. I still thing its in one of the modules, but it could also be in the BCM. Most of the configurable parameters on in the BCM.
Dealer just called back and said they aren't qualified to handle something like that. Hopefully I will hear back from alfaobd and they can help.
 

·
Registered
2019 Jeep Cherokee Trailhawk Elite
Joined
·
1,154 Posts
There are a few navigation options in alfa. Go to the body control module, then go to the hood button bottom left, then go to car configuration change, then to select options and search for navigation. Maybe try turning at least the Navigation off.
Font Rectangle Screenshot Number Parallel

Communication Device Font Mobile device Rectangle Gadget
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #23 ·
Might be the issue. This is Non Nav and I had Nav before.

Dealer just called back and said they aren't qualified to handle something like that. Hopefully I will hear back from alfaobd and they can help.
Just found online a 4C retrofit interface f
There are a few navigation options in alfa. Go to the body control module, then go to the hood button bottom left, then go to car configuration change, then to select options and search for navigation. Maybe try turning at least the Navigation off. View attachment 218008
View attachment 218007
I will give that a shot tonight and update. My heared seats do work. The major issue is having mo volume control. The screen shows the volume going up and down but there is no change from the speakers. Thanks again for the help.
 

·
Registered
Blackbird 2019_Limited_4x4 Blk_on_Blk Tech_Lux_Nav
Joined
·
2,467 Posts
Just found online a 4C retrofit interface f
The major issue is having mo volume control. The screen shows the volume going up and down but there is no change from the speakers. Thanks again for the help.
This could be caused if the radio came from an Alpine equipped car and you have the 6 speaker system (or vis a vis), on Alpine systems, the amplifier controls the volume, whereas on the 6 speaker system, the head unit controls the volume. You might want to try the head unit sync/relearn process here (from a prior post of mine):
Here's a video I have found on the relearn that may help you - via PacAudio:
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #25 ·
This could be caused if the radio came from an Alpine equipped car and you have the 6 speaker system (or vis a vis), on Alpine systems, the amplifier controls the volume, whereas on the 6 speaker system, the head unit controls the volume. You might want to try the head unit sync/relearn process here (from a prior post of mine):
Here's a video I have found on the relearn that may help you - via PacAudio:
I will give this a shot as well. You guys are great. This is my first Jeep product and my General Motors experience doesn't seem to be worth much!
 

·
Registered
14 ,16,and a 19 limited KL all 3.2l
Joined
·
185 Posts
Poco says (Hi my name is cliff, is your odometer flashing, if so you have to do a proxy alingment with a scanner, witech if have)

no I do not. I don't have the alfaobd .as stated if just for changing things I pass on getting it as I would surely screw-up the proxy alignment. Happy with what I have. i would know what to change anyway
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #29 ·
Did you ever get this figured out?
Nope. I went aftermarket with Pioneer, then had issues with a new Samsung S22 Ultra. Think the issue was the radio was from a 9 speaker system and mine was a 6. Found a company out of China that offers a solution. It's not perfect with having to mount a button to switch back and forth. But you install a second circuit board in the radio and install their control unit. I have essentially added android auto to my factory radio.
 

·
Registered
Joined
·
7 Posts
Nope. I went aftermarket with Pioneer, then had issues with a new Samsung S22 Ultra. Think the issue was the radio was from a 9 speaker system and mine was a 6. Found a company out of China that offers a solution. It's not perfect with having to mount a button to switch back and forth. But you install a second circuit board in the radio and install their control unit. I have essentially added android auto to my factory radio.
It sounds like you're talking about the wireless carplay module. I purchased one of these but my backup camera never worked while I was using carplay. Does yours work?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #33 ·
21 - 34 of 34 Posts
Top