2014+ Jeep Cherokee Forums banner
21 - 40 of 40 Posts

·
Registered
Joined
·
3,159 Posts
Welcome arianas26 to the forum.
Could you tell us which Jeep you have, how many miles is on it, and how old the battery is?
Is it like Phoenix, AZ in August or Northern Maine in January where you live, this helps us predict your situation
 

·
Registered
Joined
·
4 Posts
I have 2014 Jeep Cherokee Latitude 3.2L. Battery is going to be 2 years old in a few days. I drove out of town 2 1/2 hours away, did what I had to do and when it was time to drive again didn’t start. Tried jump starting it different ways and nothing, going to check the battery at an auto zone right now.
 

·
Registered
Joined
·
4 Posts
Tried jumping it 3 different ways, ended up towing it home and by home I mean 2 1/2 hours away :(
Going to take the battery to get checked right now, it’s gonna be 2 years at the end of the month since I got that battery.
 

·
Registered
Joined
·
339 Posts
Tried jumping it 3 different ways, ended up towing it home and by home I mean 2 1/2 hours away :(
Going to take the battery to get checked right now, it’s gonna be 2 years at the end of the month since I got that battery.
Jumping should have worked ok if it was only the battery tho I'd have thought?
 

·
Registered
Joined
·
4 Posts
My mechanic said if the battery is completely dead then jump starting won’t work, have to charge it for a good 2-3 hours
 

·
Registered
Joined
·
10,865 Posts
My mechanic said if the battery is completely dead then jump starting won’t work, have to charge it for a good 2-3 hours
Hmmm. Did you get any action from the starter while jump starting ? What did you use to jump start it (other vehicle with engine off ? small car ?).
True that a totally dead battery will suck most jump starting current thrown at it, but yours was still holding some power on the first leg of your little trip. A boost from a healthy battery should have produced some cranking at least...

If it is the battery, great. If not... look for a connection issue (bad ground possibly), or a starter issue (rare for KLs but possible).
 

·
Registered
Joined
·
3 Posts
I have a 2014 Cherokee Trailhawk 2.4L. The remote starters won't work nor will the push start button. The Jeep has power and all accessories come on but it won't start. We have put in a new battery, so I know its not that. The brake pedal is hard and doesn't depress when its stepped on. We were able to get the Jeep into neutral once and tried to start it but still would not. Anyone have any suggestions or have had this issue? I have contacted several Jeep dealer service techs but no one knows what the problem is.
Have you tried the key fob battery? Thats where I have narrowed down my no start on 2014 Jeep Cherokee Latitude.
 

·
Registered
Joined
·
10,865 Posts
Have you tried the key fob battery? Thats where I have narrowed down my no start on 2014 Jeep Cherokee Latitude.
That was 2 years ago. Is your situation resolved ?
 

·
Registered
Joined
·
3 Posts
That was 2 years ago. Is your situation resolved ?
Not completely Mark. Although I had some strange resolutions today. After being sure I had a new key fob battery I attempted
That was 2 years ago. Is your situation resolved ?
Not completely Mark, although I had some strange resolutions today. After being sure I had a new key fob battery I attempted to start it in the usual way. With no success, I started thinking of what I read about programing a new key fob. So I attempted one of those directions of holding down the unlock button while turning the key to start. AND WOO HOO! Just like that it started. Now it has worked three times after dealing with a no start, leaving my car behind for days, and finally a tow. I know it is not the way it is supposed to work but is getting me by for now until I can afford the small fortune they want for a new key fob, thats not necessarily guarenteed to solve the problem.
 

·
Registered
Joined
·
10,865 Posts
Not completely Mark. Although I had some strange resolutions today. After being sure I had a new key fob battery I attempted

Not completely Mark, although I had some strange resolutions today. After being sure I had a new key fob battery I attempted to start it in the usual way. With no success, I started thinking of what I read about programing a new key fob. So I attempted one of those directions of holding down the unlock button while turning the key to start. AND WOO HOO! Just like that it started. Now it has worked three times after dealing with a no start, leaving my car behind for days, and finally a tow. I know it is not the way it is supposed to work but is getting me by for now until I can afford the small fortune they want for a new key fob, thats not necessarily guarenteed to solve the problem.
Yikes ! Well I'm not familiar with fob problems so can't help you much...

Glad you got it started again though. Do keep us posted ;)
 

·
Registered
Joined
·
4 Posts
Welcome to JCC :)

That member was here 11 months ago and has not logged into the forum since, so I doubt we'll hear from them again. But maybe we will..
So can you tell us more about your specific situation ? Model year and engine for starters, then perhaps a short list of problems and fixes attempted... would get us rolling. Thx.
HI! I am new to the whole forum thing. I have a 2016 Cherokee Limited that seems to have the same issue. Power is there but the jeep won't start. Was there anything solved on this? It sat overnight, wasn't too cold, only about -3 degrees. All the lights and everything come on when I try and start but the engine won't turn over. No warning lights or notifications, other than the regular cycle through the warning lights when in accessory mode.

Any help would be appreciated - currently stuck home from work - whoops :)

-ashley
 

·
Registered
Joined
·
875 Posts
First thing to check is the car battery. It needs to be properly load tested with an electronic tester. Just because lights,dash,etc come on does NOT mean your battery is good! Just replaced my battery on my 2018 with 24000 miles. Drove fine one day, next morning d e a d . Dash lit up, radio lit up, but no start. Charged the battery for 30 mins, then attached my jump start unit, kicked right over. Drove to batteries plus for a X2 AGM. No more issues…


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
10,865 Posts
HI! I am new to the whole forum thing. I have a 2016 Cherokee Limited that seems to have the same issue. Power is there but the jeep won't start. Was there anything solved on this? It sat overnight, wasn't too cold, only about -3 degrees. All the lights and everything come on when I try and start but the engine won't turn over. No warning lights or notifications, other than the regular cycle through the warning lights when in accessory mode.

Any help would be appreciated - currently stuck home from work - whoops :)

-ashley
Hey Ashley, welcome to JCC :)

As @ArizonaFred said, chances are very high the problem is your battery. Are you the original owner ? If so, has the original battery been replaced yet ?

Did this happen all of a sudden ? Any other signs ?

If you can put a charger on the battery, try that first... and you may have to leave it on for 12-24 hours if the battery is really drained.
 

·
Registered
Joined
·
4 Posts
Hey Ashley, welcome to JCC :)

As @ArizonaFred said, chances are very high the problem is your battery. Are you the original owner ? If so, has the original battery been replaced yet ?

Did this happen all of a sudden ? Any other signs ?

If you can put a charger on the battery, try that first... and you may have to leave it on for 12-24 hours if the battery is really drained.
Mark,
Thanks for the quick response. It was working fine yesterday, went to leave for work this morning and it wouldn't start. I am the second owner, and I am unsure if the battery has been replaced. A few weeks ago my "stop/start" had an error and stopped working, but the error message went away on its own. I am going to try and get it boosted and see if I can get a charger for it.

-Ashley
 

·
Registered
Joined
·
10,865 Posts
Mark,
Thanks for the quick response. It was working fine yesterday, went to leave for work this morning and it wouldn't start. I am the second owner, and I am unsure if the battery has been replaced. A few weeks ago my "stop/start" had an error and stopped working, but the error message went away on its own. I am going to try and get it boosted and see if I can get a charger for it.

-Ashley
Ok... the Stop/Start error is a sign. Did you happen to scroll through the menu (center display) to see what the exact Stop/Start error was ? If so, was it something like 'Stop/Start unavailable battery charging' ?

If the battery is almost dead, a boost may not be enough to allow the Jeep to start and run afterwards, but at least you'll see if it does turn over.

You mentionned -3C outside, so I'll guess you're somewhat up North ? Yukon perhpas ? Just curious.

Best thing to do would be to get the battery tested. Most shops can do this. But if the Jeep starts with a boost, that pretty much points to a dying battery. Which engine do you have in the Limited ? V6 or 4 cylinder ?

Edit to add : just checked a weather map. Wow... it's cold in the Prairies and out West !! Brrr.... Quite the opposite in Eastern Canada...
 

·
Registered
Joined
·
4 Posts
Ok... the Stop/Start error is a sign. Did you happen to scroll through the menu (center display) to see what the exact Stop/Start error was ? If so, was it something like 'Stop/Start unavailable battery charging' ?

If the battery is almost dead, a boost may not be enough to allow the Jeep to start and run afterwards, but at least you'll see if it does turn over.

You mentionned -3C outside, so I'll guess you're somewhat up North ? Yukon perhpas ? Just curious.

Best thing to do would be to get the battery tested. Most shops can do this. But if the Jeep starts with a boost, that pretty much points to a dying battery. Which engine do you have in the Limited ? V6 or 4 cylinder ?
I have the V6, I live in Alberta so that's a normal temp for this time of year. I just boosted it and it started. Going to take it to see if I can get the battery tested. It was "stop/start unavailable" but I don't remember the exact message.
 

·
Registered
Joined
·
10,865 Posts
I have the V6, I live in Alberta so that's a normal temp for this time of year. I just boosted it and it started. Going to take it to see if I can get the battery tested. It was "stop/start unavailable" but I don't remember the exact message.
I edited my message (late) after I looked at a weather map. It's cold out West... in the East, pretty warm, we're expected to hit 23C today (73F) !

Thanks for the details. Yeah, it sounds like the battery needs to be replaced.

Do you have access to a Canadian Tire ? Costco ?
 
  • Like
Reactions: ArizonaFred

·
Registered
Joined
·
10,865 Posts

·
Registered
Joined
·
4 Posts
I edited my message (late) after I looked at a weather map. It's cold out West... in the East, pretty warm, we're expected to hit 23C today (73F) !

Thanks for the details. Yeah, it sounds like the battery needs to be replaced.

Do you have access to a Canadian Tire ? Costco ?
I have both close to me! Are they the best places to get the battery checked?
 

·
Registered
Joined
·
10,865 Posts
I have both close to me! Are they the best places to get the battery checked?
Actually I linked to them so you could get a sense of a) which bettery you need and b) how much they cost.

Not sure Costco can test batteries though. Canadian Tire : I'm sure they can test it, then replace it on the spot if bad. Price difference between those two places is minimal (for identical batteries, just a different label).

If Canadian Tire can let you come in today, I'd go there. Maybe you could give Coscto a call, to see if they test batteries, and if they do, do they have the Energizer H7 AGM in stock... before you go there.
 
  • Like
Reactions: Flybynightcru
21 - 40 of 40 Posts
Top