2014+ Jeep Cherokee Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I had my 2019 Jeep Cherokee Trailhawk in for an oil change and had some issues I wanted addressed. First the start/stop not working (battery charging message). Second was condensation in the driver side tail light. Third was to see if they could update the Uconnect to try and get the Jeep Offroad Pages. The battery ended up being bad and is going to be replaced under warranty. They said that it only failed after they did an hour long test. They had to order a tail light due to the condensation. They tried to update the Uconnect and it would not update, they ended up ordering a new radio.

Sent from my SM-G975W using Tapatalk
 

·
Registered
Joined
·
18 Posts
I had the same experiences as you, but my service wasn't quite as good. Battery started going bad with the same symptom, but they did a quick test and said it was fine. Eventually start/stop completely stopped working because the battery degraded further and then they replaced it under warranty.

After that my PTU blew up on the highway while I was out of town visiting my folks.Had to have it towed to that town's dealer. In that case they ended up having it for two weeks after first claiming nothing was wrong with it, but then I was able to show them a video of the PTU failing a 2nd time and they believed me. Drained PTU oil and found metal shavings, replaced the PTU. I had a rental vehicle for the whole period and fortunately they covered it under warranty, but it did require some convincing for them to do so unfortunately.

My radio would occasionally shut off while driving, so I showed them the TSB regarding that issue and also requested trying to get ORP working. They tried to update to 39.5 but it failed, so they ordered me a new radio which updated fine to 39.5. However unfortunately they could not figure out how to enable ORP.

I am still generally happy with the service as they have covered lots of things under warranty, but it could have been better.

Where is your dealer located?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
I had the same experiences as you, but my service wasn't quite as good. Battery started going bad with the same symptom, but they did a quick test and said it was fine. Eventually start/stop completely stopped working because the battery degraded further and then they replaced it under warranty.

After that my PTU blew up on the highway while I was out of town visiting my folks.Had to have it towed to that town's dealer. In that case they ended up having it for two weeks after first claiming nothing was wrong with it, but then I was able to show them a video of the PTU failing a 2nd time and they believed me. Drained PTU oil and found metal shavings, replaced the PTU. I had a rental vehicle for the whole period and fortunately they covered it under warranty, but it did require some convincing for them to do so unfortunately.

My radio would occasionally shut off while driving, so I showed them the TSB regarding that issue and also requested trying to get ORP working. They tried to update to 39.5 but it failed, so they ordered me a new radio which updated fine to 39.5. However unfortunately they could not figure out how to enable ORP.

I am still generally happy with the service as they have covered lots of things under warranty, but it could have been better.

Where is your dealer located?
My dealer is in Nova Scotia Canada. Where is your dealer Firehawk989?

Sent from my SM-G975W using Tapatalk
 

·
Registered
Joined
·
62 Posts
That's awesome to hear ... we have a very good dealer up here in the great white north to .. Twin Motors they have 3 dealers in the north of Manitoba and one in the south... all of them are about 4 hour drive apart from each other.
 
1 - 6 of 6 Posts
Top