2014+ Jeep Cherokee Forums banner
1 - 7 of 7 Posts

· Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
That's my new issue.
Jepp cherokee trailhawk 2015.
The car went to the dealer to fix the 4L that was not engaging. They said they have replaced the "powertrain".
Now the 4L works however, the car came back showing a new issue.

If I take a right turn on inertia/momentum, even a stiff turn, it's ok no weird sound but when I take a right turn AND step on the gas to make the car move to speed up, then comes the weird sound. Like something is loose or slipping.

The car is covered by an extended warranty, but the dealer is trying to deceive me by saying that the sound is normal.
NORMAL??? WHAT? How normal if it was not there before???

Any ideas?
 

· Registered
Joined
·
12,919 Posts
That's my new issue.
Jepp cherokee trailhawk 2016.
The car went to the dealer to fix the 4L that was not engaging. They said they have replaced the "powertrain".
Now the 4L works however, the car came back showing a new issue.

If I take a right turn on inertia/momentum, even a stiff turn, it's ok no weird sound but when I take a right turn AND step on the gas to make the car move to speed up, then comes the weird sound. Like something is loose or slipping.

The car is covered by an extended warranty, but the dealer is trying to deceive me by saying that the sound is normal.
NORMAL??? WHAT? How normal if it was not there before???

Any ideas?
Hi,

So early August you posted about your PTU being replaced (on your 2015 TH, not 2016 ?). Did they replace anything else ? (just curious). You also mentionned back them you pulled the ABS fuse to disable ESC : could you elaborate on that, as in what was your goal ?

Being in Abu Dhabi, I'm sure you have limited dealership choices.

Could you possibly record this sound ?
 

· Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Hi,

So early August you posted about your PTU being replaced (on your 2015 TH, not 2016 ?). Did they replace anything else ? (just curious). You also mentionned back them you pulled the ABS fuse to disable ESC : could you elaborate on that, as in what was your goal ?

Being in Abu Dhabi, I'm sure you have limited dealership choices.

Could you possibly record this sound ?
1- Yes, they replaced and the 4L is now working ok. The car is 2015, if I typed 2016 was a typo, my mistake sorry. The new weird issue started after the car cam from the 4L repair.
2- I´m trying to disable the traction control to drive the car on the sand not being limited by the ESC. So far it was not possible.
3- I´ll try to record a video tomorrow.
4- Yes, only one dealer in Abu Dhabi and another one in Dubai :(
 

· Registered
Joined
·
4,362 Posts
Check your last repair receipt and see if the shop has a parts and/or labor warranty.
You will have to read the fine print.
Even if there is no implied Warranty maybe the dealer would at least try to treat a customer fairly.
You probably spent a lot of money, the least they can do is try to do the repair correctly.
 

· Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Just to update this treat.

I went back to the dealer (remember the car is still covered under an extended warranty), I explained the timeline, and described the issues. After some youtube research, I was able to give them a lead...
The problem was the left side axel shaft, possibly someone made a mistake during the PTU rassemblement, therefore causing damage to the tip of the axel shaft. They replaced the axle shaft under warranty and the roaring noise has gone.
 
1 - 7 of 7 Posts
Top