2014+ Jeep Cherokee Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
356 Posts
Discussion Starter #1
My odometer started flashing non-stop about every second. Has this happened to anyone or know of a fix?

I am not sure if it was flashing when I picked the car up from the dealer service dept but I don't think it was. I had the latest TSB performed, the adaptive learn and the TCM reprogrammed.
 

·
Registered
Joined
·
39 Posts
Another person just posted about the same thing. Here's my reply, which is pretty much dead on for what happened to you:

When I took mine in for a minor update, I left the shop with a flashing odometer. It was caused by a failed update and they had to order a new computer. I didn't bother asking which one. I do know it didn't change any settings inside the vehicle so I suspect it was some sort of engine control computer.
 

·
Registered
Joined
·
356 Posts
Discussion Starter #3
Yeah I just noticed the other thread, odd that it just happened to two of us.
 

·
Registered
Joined
·
356 Posts
Discussion Starter #4
Nothing had to be replaced, said they just had to reconfigure the computer.
 

·
Registered
Joined
·
471 Posts
I know from other Fiat vehicles, that a flashing odometer indicates a CAN-BUS failure. One of the controllers connected to CAN does not send a correct idle message during start-up. WITECH tester from dealership should be able to tell You, which one it is. Disconnecting the battery for 2 minutes may also help (sometimes).

I had this on my Alfa Romeo 159 and we found out, that a faulty usb-stick screwed up the entertainment-system. Just unplugged the stick and flashing was gone.
 

·
Registered
Joined
·
1 Posts
Same thing just happened to my brand new TrailHawk...600 miles. Service 4x4, check engine light, no light at 4x4 shift knob, dash says 4x4 not available, and odometer flashing. Tried removing both battery cables after checking for codes, as there were none. Still does it. Back to the dealership and see what excuse I get.
 

·
FCA Customer Support Group
Joined
·
1,369 Posts
Same thing just happened to my brand new TrailHawk...600 miles. Service 4x4, check engine light, no light at 4x4 shift knob, dash says 4x4 not available, and odometer flashing. Tried removing both battery cables after checking for codes, as there were none. Still does it. Back to the dealership and see what excuse I get.
Hi swarnock,

I'm so sorry to hear about this on your brand new Jeep! Please feel free to send me a PM with your VIN if you need additional assistance.

Kori
Jeep Social Care Specialist
 

·
Premium Member
Joined
·
2,850 Posts
This was what happened the first time


A flash of the computer and everything was fine, I was able to drive it to the dealership the next day



This is it acting up again a few weeks ago


I let it sit for a few hours and the problem went away and hasn't come back since so I didn't worry about taking it in
 

·
Registered
Joined
·
8 Posts
I have had a flashing odometer on my 2014 Cherokee Trailhawk for about 6 months. Not sure what started it but it almost seems like it started around the same time I had a OEM fog light go out. I have mentioned it to my dealership a couple times now and they claimed they have never heard of it...
 

·
Registered
Joined
·
90 Posts
On my 2019 that happened around the 400 mile mark, they had to replace the forward facing camera, and then resynch the computer
 

·
Registered
Joined
·
72 Posts
On my 2019 that happened around the 400 mile mark, they had to replace the forward facing camera, and then resynch the computer
Same thing happened to my 19 at about 8000 miles.
 

·
Registered
Joined
·
1 Posts
I had an issue where my front camera had to be recalibrated. I had messages regarding

My odometer started flashing non-stop about every second. Has this happened to anyone or know of a fix?

I am not sure if it was flashing when I picked the car up from the dealer service dept but I don't think it was. I had the latest TSB performed, the adaptive learn and the TCM reprogrammed.
I had an issue where my front camera had to be recalibrated. I had messages regarding lane sensing and cruise control being inoperative and I noticed the odometer flashing. All were corrected at dealer by reloading software.
 

·
Registered
Joined
·
35 Posts
My odometer started flashing yesterday. Trip to dealer Tuesday. This is the 3rd incident since i bought. First was screen went blank then came back on. A few days later i could not turn off stereo nor control anything on the screen, after about 10 minutes everything worked as it should. Dealer did an update and all is well so far with the screen. Lets see what they have to say about flashing odometer.2019 TH with 6500 miles.
 

·
Registered
Joined
·
90 Posts
Mine is flashing again at 8700 miles, and lane assist idntborking I’m starting to think the echo package wasn’t worth it. The other time they replaced the forward facing camera
 

·
FCA Customer Support Group
Joined
·
1,369 Posts
My odometer started flashing yesterday. Trip to dealer Tuesday. This is the 3rd incident since i bought. First was screen went blank then came back on. A few days later i could not turn off stereo nor control anything on the screen, after about 10 minutes everything worked as it should. Dealer did an update and all is well so far with the screen. Lets see what they have to say about flashing odometer.2019 TH with 6500 miles.
Mine is flashing again at 8700 miles, and lane assist idntborking I’m starting to think the echo package wasn’t worth it. The other time they replaced the forward facing camera
Hi Weyph and tsc,
We're sorry to hear about this. Please send us a private message if you need any assistance with getting this addressed by your dealer.
Lydia
Jeep Social Care Specialist
 

·
Registered
Joined
·
447 Posts
I had an issue where my front camera had to be recalibrated. I had messages regarding lane sensing and cruise control being inoperative and I noticed the odometer flashing. All were corrected at dealer by reloading software.
I had the same problem dealer stop the odometer from flashing till the lane sensing issue got fixed now everything is working great
 

·
Registered
Joined
·
35 Posts
Got mine back this afternoon. No more odometer flashing. Ticket shows "completed reconfiguration of cluster assembly". Also asked about any TSB's and was told there are none right now for the 2019 TH.
 

·
Registered
Joined
·
90 Posts
I just received mine back from Enumclaw Cjdr in Washington, they said they did the proxy alignmen5 for my lane assist that was disabled now if I get within a foot of the right fog line the steering wheel pulls back to the other side, they are also replacing my non-nav 8.4 uconnect because when my apple phone is connected CarPlay and apple maps shows me in a town 200 miles away, the service writer trued her phone and it did the same thing, they are ordering another radio and i’ve Had to ask them to schedule another appt in two weeks. Kind of frustrating that I specifically had to ask them to schedule it otherwise they would not have any loaner cars.
 

·
Registered
Joined
·
35 Posts
Once again odometer starts flashing. Since the last time this happened the only upgrade Ive done is install a northstar battery roughly 7 or so months ago. Dealer repalced the whole puter screen for delamanting about 2 or 3 months ago. On 7/19/20 odometer starts flashing. Went to dealer right away and they had the following codes: 1)ECU Configuration mismatch-not configured 2) rear speaker output-circuit open. Drove it every day since then and noticed nothing different in the way it drove or anything else. A month ago I did have a little bit of a jerky trans issue for about 10 minutes when on a trip when I was slowing down to stop but this has never happened again. On 7/20 tried to make apt with dealer I bought it from for them to check it out. No loaner car available . Yesterday dealer calls and says they now have a loaner. Took it in. Today they say the ECB needs to be replaced to solve the issues. Anyone else have to have the ECB replaced? School me on this? From research this seems to control a lot of things. BTW part wont be here till Tuesday.
 

·
Registered
Joined
·
1,836 Posts
There isn't any such thing as an ECB.
The only thing close is ECM, electronic control module.
Get the Mopar part number of the real part from your dealer.
 
1 - 20 of 22 Posts
Top