2014+ Jeep Cherokee Forums banner
1 - 5 of 5 Posts

·
Registered
14 ,16,and a 19 limited KL all 3.2l
Joined
·
172 Posts
Discussion Starter · #1 ·
Second time my 2016 cherokee latitude 3.2l. first I thought because son went from r to park. cleared code 2 weeks ago. yesterday my son called said check engine light on with service transmission soon on dash but jeep driving normal. any fixes besides a range sensor that I could either clean ( like the throttle body, ect) thats not inside of the tranny. I think it has less than 60,000mi on it
 

·
Vendor
Joined
·
156 Posts

·
Registered
14 ,16,and a 19 limited KL all 3.2l
Joined
·
172 Posts
Discussion Starter · #4 ·
Thanks guys. I did see that earlier on my searching. My son just told me that it went away by itself and jeep drive fine. I just had a silly thought, could it have to do with the shifter as wasn't there something about the connector or something under it that you needed to replace the shift to fix it. Sorry for all this as my mind wonders all over. lol
 

·
Registered
Joined
·
4,016 Posts
The shifter problem involves the bezel and wiring harness.
On mine all the shifter lights would illuminate. Never caused a problem.
Maybe go to a Jeep dealer and find out if there are any Recalls or applicable TSBs.
Sometimes there is an applicable TSB but they will only tell that if you complain about an issue.
Have the Service Advisor print a VIP report and review it with you.
Get you battery tested for free somewhere. I do that every couple months so hopefully I won't get surprised.
 
1 - 5 of 5 Posts
Top