2014+ Jeep Cherokee Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2015 altitude 4x4 with the v6. My check engine light has come and gone but lately it has been on consistently. Whenever I attempt to use my remote start, it starts for about 10 seconds and then shuts off. Also the start stop system pops up and says it is unavailable. I just recently changed my battery and all connects to that are right so it shouldn’t be that. Any thoughts?
Thanks in advance!
 

·
Registered
Joined
·
43 Posts
Welp....did you have the check engine light checked? Any codes? It won't just disappear lol
 
  • Like
Reactions: Hughyougonacall

·
Registered
Joined
·
6 Posts
Definitely find out what is causing the check engine light to come on. Had the same issue in my son's Grand Cherokee a few years back. The CEL came on and the remote start shut off after a few seconds. Turns out the CEL was caused by a faulty coil. We replaced the coil and the problem was fixed. If I remember right, it was explained to me that the remote start shutting off is like a "self defense" mechanism. The computer senses an issue and shuts down. I hope it's a simple fix, keep us posted.

-CG
 

·
Registered
Joined
·
9,101 Posts
I have a 2015 altitude 4x4 with the v6. My check engine light has come and gone but lately it has been on consistently. Whenever I attempt to use my remote start, it starts for about 10 seconds and then shuts off. Also the start stop system pops up and says it is unavailable. I just recently changed my battery and all connects to that are right so it shouldn’t be that. Any thoughts?
Thanks in advance!
Welcome to the forum :)

Yep you'll need to get codes for that CEL (check engine light), to begin trouble-shooting.

Just FYI : any CEL condition produces what you are experiencing with remote start and ESS, so this is normal. When the CEL condition gets corrected, you'll have both back online.

Mind if I ask which battery you got, and where ? A part number would be awesome. I just want to rule out someone didn't sell you the wrong battery.

Thx.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Welcome to the forum :)

Yep you'll need to get codes for that CEL (check engine light), to begin trouble-shooting.

Just FYI : any CEL condition produces what you are experiencing with remote start and ESS, so this is normal. When the CEL condition gets corrected, you'll have both back online.

Mind if I ask which battery you got, and where ? A part number would be awesome. I just want to rule out someone didn't sell you the wrong battery.

Thx.
Not exactly sure on the part number of the battery, but it was
Welcome to the forum :)

Yep you'll need to get codes for that CEL (check engine light), to begin trouble-shooting.

Just FYI : any CEL condition produces what you are experiencing with remote start and ESS, so this is normal. When the CEL condition gets corrected, you'll have both back online.

Mind if I ask which battery you got, and where ? A part number would be awesome. I just want to rule out someone didn't sell you the wrong battery.

Thx.
I am not sure of exact part number on the battery, it was replaced by AAA.
 

·
Registered
Joined
·
9,101 Posts
I am not sure of exact part number on the battery, it was replaced by AAA.
Hmmm. Do you have paperwork for it ? I'd really like to confirm you have the correct battery for your 2015 V6 Cherokee.

And about the CEL : are you saying you still have one yet there are no codes ?
 
1 - 7 of 7 Posts
Top